Samsung’s Basic 840 SSDs Also Affected by Slow-down Bug



/ 4 years ago

Samsung840Basic

We have previously reported on the slow-down bug happening on the Samsung EVO 840 drives and also about the fix that Samsung released a couple of weeks later. Back then, Samsung assured everyone that the bug didn’t affect the Basic or Pro models of the drive.

There were still users who claimed that it also happened on their Samsung 840 Basic drives and didn’t let off on the subject. Specially the forum-users at Computer Base, a German computer site, kept investigating and posting their results. The German division of Samsung picked up on it through the media and feedback and now it seems that there is an investigation running on the matter.

While the result of the error is the same as on the EVO 840, slow-motion speeds when reading old data, the bug doesn’t seem to originate in the same place. A new fix has to be created, so please don’t try to use the EVO 840 tool to fix your Basic model.

Samsung still says that the Pro models aren’t affected and there hasn’t been any evidence to suggest otherwise. We will keep you up updated on the 840 Basic matter for when Samsung releases a fix for these drives as well. My guess on a timeframe for the fix would be two to four weeks.

Thanks to ComputerBase for providing us with this information

Image courtesy of ComputerBase

Topics: , , , , , , ,

Support eTeknix.com

By supporting eTeknix, you help us grow. And continue to bring you the latest news, reviews, and competitions. Follow us on Facebook and Twitter to keep up with the latest technology. Share your favourite articles, chat with the team and more. Also check out eTeknix YouTube, where you'll find our latest video reviews, event coverage and features in 4K!
eTeknix FacebookeTeknix TwittereTeknix Instagram

Check out our Latest Video

Speak Your Mind

Tell us what you're thinking...
and oh, if you want a pic to show with your comment, go get a gravatar!


Optimized with PageSpeed Ninja